Thursday, 19 March 2015

"Could not verify the domain" in Azure

EMS Landing page

You are trying to add your domain to Azure and you have been given instructions for verification.

See the instructions. You have to add a TXT record to your domain DNS and configure it as shown above. See the "ampersand" that you should use for the Hostname. This is the slippery one that caught me out.

I configured the TXT record exactly as requested and everything was normal when I saved it.

However I still could not verify the domain. See the warning:

"Could not verify the domain.
Could not find the DNS record for this domain. DNS changes may take up to 72 hours to propogate. Please try again later."

Now I have plenty of experience with DNS and I've never had to wait for 72 hours to see my changes, so after a few hours I decided to do some troubleshooting.

I've used many times in the past and I was able to see that my DNS record did not exist. I did some research and this blog post put me on the right track.

It explained that the ampersand does not always work for TXT records even though you can save it without seeing any errors. It went on to say that replacing the ampersand with the domain name did the trick for the blogger. Unfortunately that did not work for me....... I left the Hostname blank.

That did the trick. Within a few minutes (less than 5) I could see my TXT record.....

......and could verify the domain.

Ready for the next step. Remember don't pay attention to the "72 hours for DNS propogation". You will be wasting valuable time.

No comments:

Post a Comment